Intellichlor high salt Slow flashing green light
4 posts / 0 new
Last post
Posted

So i finally connect my intellichlor back on since Spring is now here, i added salt, now i am getting a real slow flashing green light. i did enable it at my pentair touch control panel.
Since it s (green)flashing it seems its not generating chlorine, its set at 85% but the lights are not lit.
I went ahead and drained 2-3 inches and filled it up with fresh waster and still "high salt" URG its a 30k gallon pool and only put 7bags(40lb) of salt i done it before and never had an issue, i am thinking its the intellichlor. anyone have any suggestions?

System

Pentair control touch / panel
Pentair intelliflo
INtellichem
Intellichlor
HEater HD
Filter 420

Please Sign In to post comments
Richard's picture
Tech, Pentair
Please see page 10 for your
Richard's picture
Tech, Pentair
Posted

Please see page 10 for your water chemistry requirements, if your water is out of range, this could be causing the issue, of your salt light flashing, if your chemistry is within range, there could be a potential issue with the cell, but this will need to be verified to begin with.

Please Sign In to post comments
sorry for the delay, so i
Posted

sorry for the delay, so i cleaned the Intellichlor(just hosing it w/water) it had just a tad off calcium,check all the levels and brought the chemistry level to balance, i also have a intellichem when i plug in the salt level in the index it wont save it...ODD.. i also measure the salt and its 3800/4000 i taste it with tongue and i can't taste the salt.....this is the first time this light went off on me and i just replace this intellichlor (about) 6 months ago, at this point what do i do ? :( so bummed out

Please Sign In to post comments
i had it replaced once i try
Posted

i had it replaced once i try to email pentair but email bounces back ,can someone help, should i call?

Please Sign In to post comments