Mastertemp 125 heater hums loudly but won't fiere up
5 posts / 0 new
Last post
Posted

Hello,

My Mastertemp heater, which is about 2.5 years old now, hums loudly when I try to turn it on and the service light comes on. It sounds like an electric motor that is bound up and won't turn, like a fan that won't turn. It is out of warranty. I am trying to find someone to service it, but am having no luck getting anyone to answer any of my emails. I live in Phoenix, where there are more pools per capita than I think anywhere in the world. Can anyone help with an idea or a service provider here?

Thank you,
Steve

Please Sign In to post comments
Richard's picture
Tech, Pentair
Sounds like a possible issue
Richard's picture
Tech, Pentair
Posted

Sounds like a possible issue with the blower, please feel free to use our dealer locater below for a service technician in your area.

http://www.pentairpartners.com/dealerlocator/dealerlocatorlist.aspx

Please Sign In to post comments
Thank you, Richard.
Posted

Thank you, Richard. Unfortunately, I have sent four emails now to service providers from the list and none have responded yet. I started sending them about a week ago.

I will try some others.

Please Sign In to post comments
So... here is an update to my
Posted

So... here is an update to my situation. I actually have a Master Temp 400. I believe the model number is 460736 based on the serial number plate on the cover. I was able to get the blower and heater to turn on with the help of something a service provider wanted me to try before he came over. The blower now comes on and the heater as well, but it cycles on and off every 4-5 minutes until it gets to temperature. When this happened under warranty, a capacitor was replaced. Is there only one of these, and is it something that a DYI homeowner could probably do? The service person said he doesn't work on gas heaters. I am actually pretty capable of doing most jobs around the house/yard and at one time not long ago owned a landscaping business, but no pool experience except for replacing a pump. Still having some trouble finding someone to come and look at it. Help???

Please Sign In to post comments
Ok, so I am back with my
Posted

Ok, so I am back with my original problem. My Pentair Mastertemp 400 Natural Gas heater, which is out of warranty now, will not turn on. When I start the pool pump, then press the Heat Spa button, the blower just hums loudly. I think this points to a start capacitor that has gone bad, but am not sure and am also not exactly sure where it is. I know what a capacitor looks like, and have replaced them on the pump, but just not sure where on the heater it would be located. BTW, this was fixed by a Pentair authorized service rep at one time, but I have not paperwork for it nor was I home to see what he did when he came out. Any help would be appreciated.

Please Sign In to post comments