ScreenLogic for Mac OSX Catalina
4 posts / 0 new
Last post
Posted

I'm concerned that Pentair apps such as ScreenLogic will no longer run on my Mac if/when I update to Apple's latest version of Mac OSX (i.e., Catalina).

As you may know, with Catalina (and forever after), Apple no longer supports 32-bit applications.

It appears that Pentair apps such as ScreenLogic require several 32-bit applications (e.g., wine, xkbcomp, quartz) in order to run on OSX. Will ScreenLogic run on Catalina, which cannot run these (or any) 32-bit apps?

If not, what workarounds would you recommend? The only workaround I have now is to not upgrade to the most current version of OSX. While this is manageable for the time being, it will be increasingly untenable in the months and years ahead. :-)

Thanks for your support!
Todd

Please Sign In to post comments
Richard's picture
Tech, Pentair
This has been submitting to
Richard's picture
Tech, Pentair
Posted

This has been submitting to our engineering department regarding the issue and currently working on this, If I hear anything back, I will reply on this.

Please Sign In to post comments
Thanks, Richard. Much
Posted

Thanks, Richard. Much appreciated.
I should probably add that some segment of your Mac user base is going to update to Catalina, unaware that it may render ScreenLogic inop. Those folks will be seeking more urgent attention than those of us who held up on the update. :-P

Please Sign In to post comments
Yup, I had to upgrade to
Posted

Yup, I had to upgrade to Catalina and nothing from Pentair works anymore. Hopefully we'll see an upgrade!

Please Sign In to post comments